Microsoft DNS Outage
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 16:09 PDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2021 - 15:25 PDT
This incident affected: Denticon, Denticon Backup, Sandbox, and Denticon Two-Way Communication.