Cloud 9 performance issues

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 07:31 PDT

Identified

We are aware that some users may be experiencing slow performance while using Cloud 9.

We are carrying out remedial work to restore service and expect service to resume imminantly.
Posted Sep 04, 2026 - 07:20 PDT
This incident affected: Cloud 9 (Patient Portal).