Denticon Patient Registration Partial Outage
Incident Report for Planet DDS
Resolved
Denticon Patient Registration Issue Resolved
Posted Apr 02, 2021 - 09:48 PDT
Update
We are continuing to investigate this issue.
Posted Apr 02, 2021 - 09:47 PDT
Investigating
We are currently investigating the root cause. We hope to have this resolved as quickly as possible.
Posted Apr 02, 2021 - 09:09 PDT
This incident affected: Patient Facing Sites (Patient Registration).