Cloud9 Unavailable for Some Client Databases

Incident Report for Planet DDS

Resolved

Our Engineering Teams have confirmed that the issue is resolved.
Posted Apr 29, 2026 - 16:20 PDT

Identified

Our Engineering Tems have identified the issue and are actively working to mitigate the issue.
Posted Apr 29, 2026 - 16:10 PDT

Investigating

Our monitoring has detected performance degradation for some Cloud9 customers.

Engineering Teams are engaged to investigate the issue.
Posted Apr 29, 2026 - 16:00 PDT
This incident affected: Cloud 9 (Practice Management (cloud9ortho.com)).