Denticon Practice Analytics: We continue to observe degraded performance, and sites may be in read-only mode due to an ongoing Microsoft Azure Fabric outage. Our team is actively working with our partner to restore service back to normal operation.
Posted Oct 21, 2025 - 10:40 PDT
Identified
Denticon Practice Analytics: We continue to observe degraded performance, and sites may be in read-only mode due to an ongoing Microsoft Azure Fabric outage. Our team is actively working with our partner to restore service back to normal operation.
Posted Oct 21, 2025 - 10:39 PDT
Investigating
We’re currently experiencing degraded performance with our partner service Microsoft Azure Fabric Service which is impacting Denticon Practice Analytics. Our team is actively working with our partner to restore service back to normal operation.
Posted Oct 21, 2025 - 08:23 PDT
This incident affected: Denticon (Practice Analytics).