Cloud 9 - Degraded Peformance

Incident Report for Planet DDS

Resolved

We have full system recovery, and we will continue to monitor.
Posted May 26, 2026 - 08:20 PDT

Monitoring

A fix has been implemented, and we are confirming recovery.
Posted May 26, 2026 - 08:11 PDT

Identified

The issue has been identified, and the team is working on mitigation measures.
Posted May 26, 2026 - 07:53 PDT

Update

The team continues to investigate the intermittent degraded performance of a subset of the Cloud 9 customers.
Posted May 26, 2026 - 07:46 PDT

Investigating

We are currently investigating intermittent degradation of the Cloud 9 platform for a subset of our customers.
Posted May 26, 2026 - 07:16 PDT
This incident affected: Cloud 9 (Practice Management (cloud9ortho.com)).