DoseSpot Performance Degraded
Incident Report for Planet DDS
Resolved
DoseSpot Issue Resolved
Posted Feb 02, 2021 - 12:44 PST
Investigating
DoseSpot is experiencing issues which is causing some performance degradation in Denticon Rx module. We are currently working with DoseSpot to understand the root cause. We hope to have this resolved as quickly as possible.
Posted Feb 02, 2021 - 09:19 PST
This incident affected: DoseSpot.