AppointNow Performance Degraded

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Jul 22, 2023 - 15:46 PDT

Investigating

We are currently investigating this issue.
Posted Jul 22, 2023 - 15:42 PDT