DentalXChange - Partner Service Degredation Impacting Denticon & Cloud 9

Incident Report for Planet DDS

Resolved

Service has been confirmed as returning to normal. We will continue to monitor for any additional impact reports.
Posted Sep 01, 2026 - 07:07 PDT

Update

DentalXChange are currently reporting service degradation, which may be impacting claim processing on both Denticon & Cloud 9 platforms. We are working closely with DentalXChange to monitor impact and validate a fix once the route cause has been identified on their platform.
Posted Sep 01, 2026 - 06:07 PDT

Monitoring

DentalXChange are currently reporting service degradation, which may be impacting claim processing on both Denticon & Cloud 9 platforms. We are working closely with DentalXChange to monitor impact and validate a fix once the route cause has been identified on their platform.
Posted Sep 01, 2026 - 06:05 PDT
This incident affected: Denticon (Eligibility and Claims (DentalXchange)) and Cloud 9 (Eligibility & Claims).