DentalExchange - Partner Service Outage Impacting Denticon Eligibility and Claims
Incident Report for Planet DDS
Resolved
Our partner service DentalExchange has confirmed that services are recovered. Denticon Eligibility and Claims are operational at this time.
Posted Nov 25, 2024 - 04:41 PST
Investigating
We’re currently experiencing an outage with our partner service DentalExchange which is impacting Denticon Eligibility and Claims. Our team is actively working with our partner to restore service back to normal operation. We will provide an update in 15 minutes.
Posted Nov 25, 2024 - 04:33 PST
This incident affected: Denticon (Eligibility and Claims (DentalXchange)).