Dentiray DNS issues
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Sep 30, 2019 - 16:15 PDT
Monitoring
The issue has been resolved. We will continuing to monitor.
Posted Sep 30, 2019 - 13:06 PDT
Investigating
We are currently investigating an intermittent issue with DNS resolution for Dentiray Classic (Dentiray.com)
Posted Sep 30, 2019 - 13:04 PDT
This incident affected: Dentiray Classic.