Denticon API Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 22:40 PDT
Investigating
We are currently investigating this issue.
Posted Oct 13, 2021 - 22:35 PDT
This incident affected: Denticon API.