Users Unable to Login to Legwork

Incident Report for Planet DDS

Resolved

All accounts affected by the change have been restored, and all users should once again be able to login.
Posted Apr 27, 2026 - 10:47 PDT

Identified

The root cause of the issue has been identified as a change made within the payment processor for the affected customers, which caused some user accounts to become archived (leading to users being unable to login).

Our Engineering Teams are working with the payment processor to restore these accounts.
Posted Apr 27, 2026 - 10:01 PDT

Investigating

We are currently investigating reports of some users being unable to login to Legwork.

Our Engineering Teams are engaged and investigating.
Posted Apr 27, 2026 - 09:43 PDT
This incident affected: Legwork (Patient Engagement).