DentalXChange are now reporting restoration of their affected API services. Through internal testing, we now believe all degraded functionality within Denticon has now been restored and this issue has been resolved.
Posted Dec 10, 2025 - 14:05 PST
Monitoring
DentalXChange are reporting that full functionality has now been restored. Our initial testing would suggest functionality has been restored within Denticon - we will continue to monitor closely, but Denticon users should begin to see recovery of impacted functionality now.
Posted Dec 10, 2025 - 13:57 PST
Update
We are continuing to monitoring the status of the DentalXChange service degradation.
Posted Dec 10, 2025 - 13:26 PST
Update
Our team continues to monitoring the status of the DentalXChange service degradation.
Posted Dec 10, 2025 - 12:46 PST
Update
Our team is continuing to monitoring the status of the DentalXChange service degradation.
DentalXChange have confirmed that this service degradation is continued impact related to the issue they seen earlier today. Our team is continuing to monitor partner status while they work on a fix.
Posted Dec 10, 2025 - 11:10 PST
Identified
We’re currently experiencing an outage with our partner service DentalXChange which is may result in degraded performance when validating/submitting batch claims within Denticon. We are monitoring this issue closely with DentalXChange.
Posted Dec 10, 2025 - 10:45 PST
This incident affected: Denticon (Eligibility and Claims (DentalXchange)).