Incomplete Data Share

Incident Report for Planet DDS

Resolved

The Data Share process has completed successfully and has been resolved for the majority of customers. Planet DDS support will send a communication with an update and actions that need to be taken.

A small number of customers will see full resolution by tomorrow morning and will receive direct communication from Planet DDS Support.
Posted Jun 04, 2026 - 11:05 PDT

Monitoring

The Data Share process has completed successfully. Data Validation is in process.
Posted Jun 04, 2026 - 08:58 PDT

Identified

Planet DDS experienced an issue impacting our Data Share service resulting in incomplete data being sent to some customers' Data Share.

Our Data Engineering team has initiated the Data Share process to ensure full data is copied to each customers' Data Share.
Posted Jun 04, 2026 - 06:42 PDT
This incident affected: Denticon (Practice Analytics).