DoseSpot Performance Degraded
Incident Report for Planet DDS
Resolved
We are satisfied that the problem has been resolved and are now closing this incident.
Posted Oct 20, 2020 - 08:15 PDT
Investigating
DoseSpot is experiencing issues which is causing some performance degradation in Denticon Rx module. We are currently working with DoseSpot to understand the root cause. We hope to have this resolved as quickly as possible.
Posted Oct 20, 2020 - 07:06 PDT
This incident affected: DoseSpot.