Denticon Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 09:37 PST
Investigating
We are experiencing unusually heavy loads which is causing some performance degradation in Denticon. We are currently investigating the root cause. We hope to have this resolved as quickly as possible.
Posted Nov 17, 2020 - 08:44 PST
This incident affected: Denticon Group (Denticon).