Denticon Practice Management Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 20:16 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 18, 2024 - 18:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2024 - 18:42 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 18:15 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 17:52 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 17:38 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 17:20 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 17:02 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 16:33 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 16:13 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2024 - 15:41 PDT
Identified
Microsoft has identified Azure platform related issues impacting Planet DDS systems. Planet DDS engineering teams are working towards resolutions.
Posted Jul 18, 2024 - 15:33 PDT
Investigating
We’re currently experiencing degraded performance with one or more of our services. We apologize for any inconvenience. Our team is working to restore service back to normal operation. Please see https://status.planetdds.com/ for detailed information on this issue.
Posted Jul 18, 2024 - 15:19 PDT
This incident affected: Denticon (Practice Management, Imaging (Apteryx)).