Issue has been resolved and services have been resolved. We will continue to monitor.
Posted May 06, 2026 - 08:54 PDT
Update
The issue has been identified and a fix is being implemented. Next update will be 30 minutes,
Posted May 06, 2026 - 08:40 PDT
Update
The issue has been identified and a fix is being implemented. Next update will be 30 minutes,
Posted May 06, 2026 - 08:04 PDT
Update
The issue has been identified and a fix is being implemented. Next update will be 30 minutes,
Posted May 06, 2026 - 07:35 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 06, 2026 - 07:13 PDT
Update
Our engineering team is continuing to investigate this issue.
Posted May 06, 2026 - 06:57 PDT
Update
Our engineering team are continuing to investigate this issue and look mitigation approaches.
Posted May 06, 2026 - 06:41 PDT
Update
We are continuing to investigate this issue.
Posted May 06, 2026 - 06:23 PDT
Update
Our engineering team is continuing to investigate this issue.
Posted May 06, 2026 - 06:07 PDT
Investigating
We’re currently experiencing an outage with Patient Engagement, whereby users are unable to log in. We apologize for any inconvenience. Our team is working to restore service back to normal operation. Our team is actively working to restore service back to normal operation.
Posted May 06, 2026 - 05:51 PDT
This incident affected: Legwork (Patient Engagement).