www.planetdds.com - Service Outage

Incident Report for Planet DDS

Resolved

Full service to www.planetdds.com has been restored.
Posted Dec 05, 2025 - 01:25 PST

Monitoring

Issue has been resolved. We are now monitoring.
Posted Dec 05, 2025 - 01:15 PST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 01:12 PST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 01:11 PST

Investigating

We’re currently experiencing an outage with www.planetdds.com. We apologize for any inconvenience. Our team is actively working to restore service back to normal operation. Denticon can be accessed at w1.denticon.com. We will provide an update in 15 minutes.
Posted Dec 05, 2025 - 01:11 PST
This incident affected: Denticon (Practice Management).