Microsoft Azure Services Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 06:52 PDT
Investigating
We’re currently experiencing degraded performance impacting Denticon and Apteryx due to an ongoing issue with Microsoft Azure impacting customers using the AT&T ISP. We apologize for any inconvenience. We are currently monitoring the situation. Please see https://azure.status.microsoft/en-us/status for detailed information on this issue.
Posted Sep 12, 2024 - 06:23 PDT
This incident affected: Denticon (Practice Management, Patient Communication, Practice Analytics, Reports, Imaging (Apteryx), API (Existing, New), Payment Processing, Patient Facing Application, Eligibility and Claims (DentalXchange)) and Apteryx (XVWeb Viewer, XVWeb (Single Sign On), XVWeb AI Integration, DICOM - Image Retrieval, DICOM - Image Storage, DCV - Token Registration Server).