AppointNow Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted May 15, 2022 - 05:47 PDT
Investigating
We are currently investigating this issue.
Posted May 15, 2022 - 05:38 PDT
This incident affected: Patient Facing Sites (AppointNow).