DentalXChange - Partner Service Degradation Impacting Denticon & Cloud 9

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 17:26 PDT

Investigating

We have received notifications from DentalXchange that they are seeing issues.

We are monitoring client impact.
Posted Sep 01, 2026 - 11:18 PDT
This incident affected: Denticon (Eligibility and Claims (DentalXchange)) and Cloud 9 (Eligibility & Claims).