Denticon - Patient Communications Service Performance Degraded

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 06:26 PDT

Update

The issue experienced with Denticon - Patient Communications has now been resolved - we apologize for any inconvenience caused during this service degradation.
Posted Mar 28, 2025 - 06:24 PDT

Update

We’re still experiencing degraded performance with Denticon - Patient Communications. We apologize for any inconvenience. Our team continues working to restore this service back to normal operation.
Posted Mar 28, 2025 - 05:56 PDT

Investigating

We’re currently experiencing degraded performance with Denticon - Patient Communications. We apologize for any inconvenience. Our team is actively working to restore service back to normal operation.
Posted Mar 28, 2025 - 05:18 PDT
This incident affected: Denticon (Patient Communication).