Denticon - Partner Service Outage Impacting Eligibility & Claims

Incident Report for Planet DDS

Resolved

This partner incident has now been resolved.
Posted Jul 24, 2025 - 07:17 PDT

Monitoring

Our partner has implemented a fix and reporting all services as operational - we will continue to monitor closely.
Posted Jul 24, 2025 - 06:41 PDT

Investigating

We’re currently experiencing an outage with our partner service (Dental XChange) which may be impacting Eligibility & Claims functionality for some users within Denticon. Our team is actively working with our partner to restore service back to normal operation.
Posted Jul 24, 2025 - 05:21 PDT
This incident affected: Denticon (Eligibility and Claims (DentalXchange)).