AWS - Partner Service Performance Degraded Impacting Denticon and Cloud 9

Incident Report for Planet DDS

Resolved

The incident has been resolved, with no issues observed on Denticon or Cloud9.
Posted Oct 20, 2025 - 11:42 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:27 PDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 07:24 PDT

Monitoring

A fix has been implemented by AWS.
Both Denticon and Cloud9 are operating normally, and we continue to monitor system performance.
Posted Oct 20, 2025 - 02:38 PDT

Investigating

We’re currently experiencing degraded performance with our partner service AWS which might impact Denticon and Cloud 9 applications. Our team is actively working with AWS to restore service back to normal operation.
Posted Oct 20, 2025 - 02:32 PDT
This incident affected: Denticon (Practice Management) and Cloud 9 (Practice Management (cloud9ortho.com)).