Through internal testing, we have observed recovery of all DentalXChange related functionality across both Denticon & Cloud 9. This incident has now been resolved.
Posted Dec 10, 2025 - 07:19 PST
Update
DentalXChange is reporting the issue has been mitigated. Our internal team is observing gradual recovery of DentalXChange services, however we are continuing to test before we are able to confirm full functionality has been restored.
Posted Dec 10, 2025 - 06:59 PST
Update
Our team is continuing to actively monitoring the status of the DentalXChange outage.
Posted Dec 10, 2025 - 06:30 PST
Update
Our team is actively monitoring the status of the DentalXChange outage.
Posted Dec 10, 2025 - 05:56 PST
Update
Our team is actively monitoring the status of the DentalXChange outage.
Posted Dec 10, 2025 - 05:31 PST
Update
Our team is actively monitoring the status of the DentalXChange outage.
Posted Dec 10, 2025 - 05:05 PST
Update
Our team is actively monitoring the status of the DentalXChange outage.
Posted Dec 10, 2025 - 04:50 PST
Monitoring
We’re currently experiencing degraded performance with Eligibility and Claims processing due to an outage with DentalXChange. We apologize for any inconvenience. Our team is actively monitoring the status of the outage.
We’re currently experiencing degraded performance with Eligibility and Claims processing due to an outage with DentalXChange. We apologize for any inconvenience. Our team is actively monitoring the status of the outage.
Posted Dec 10, 2025 - 03:51 PST
This incident affected: Denticon (Eligibility and Claims (DentalXchange)) and Cloud 9 (Eligibility & Claims).