Cloud9 – Service Partner Degradation Intermittently Impacting Some User Payments

Incident Report for Planet DDS

Resolved

Payments are processing normally, and no issues have been observed.
Posted Sep 17, 2025 - 16:08 PDT

Monitoring

Payments have been processing normally since 2:00 PM PT. We are working with our partner services team to confirm the root cause.
Posted Sep 17, 2025 - 15:21 PDT

Investigating

We’re currently experiencing an issue with one of our partner services which may be impacting payments for some users intermittently within Cloud9.  Our team is actively working with our partner to restore service back to normal operation.
Posted Sep 17, 2025 - 13:11 PDT
This incident affected: Cloud 9 (Payment Processing).