[Denticon] - [Practice Management] Service Performance Degraded

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 14:17 PDT

Investigating

We’re currently experiencing degraded performance with Denticon Practice Management affecting appointment scheduling functionality. We apologize for any inconvenience. Our team is actively working to restore service back to normal operation.
Posted Jun 12, 2025 - 13:38 PDT
This incident affected: Denticon (Practice Management).