Dentilytics Enterprise is Down
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Jan 02, 2022 - 13:32 PST
Investigating
We are currently investigating this issue.
Posted Jan 02, 2022 - 13:32 PST
This incident affected: Dentilytics Enterprise.