Patient Portal is Down

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Dec 31, 2021 - 16:43 PST

Investigating

We are currently investigating this issue.
Posted Dec 31, 2021 - 16:42 PST