[Denticon] - [DPC] Service Performance Degraded

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 10:21 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 10:19 PDT

Investigating

We’re currently experiencing degraded performance with [Denticon DPC]. We apologize for any inconvenience. Our team is actively working to restore service back to normal operation.
Posted Jun 25, 2025 - 08:52 PDT
This incident affected: Denticon (Patient Communication).