Internet wide Microsoft E-Mail outage.

Incident Report for Planet DDS

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 06:54 PDT

Update

We are aware that this issue continues to impact users across the internet as well as our own users, we continue to monitor and escalate to our vendors.
Posted Aug 16, 2026 - 05:24 PDT

Update

We are continuing to monitor the ongoing Microsoft outage. We will update once we have additional information.
Posted Aug 15, 2026 - 12:06 PDT

Monitoring

We have been made aware of an outage impact Microsoft E-Mail users across the internet.

While this issue is outside of our control, this may impact E-mail's (Appointment reminders etc) sent to MSFT user's during this time.

We are monitoring this situation and it's impact.
Posted Aug 15, 2026 - 09:02 PDT