Denticon Practice Management Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Jun 26, 2024 - 07:02 PDT
Investigating
We’re currently experiencing degraded performance with one or more of our services. We apologize for any inconvenience. Our team is working to restore service back to normal operation. Please see https://status.planetdds.com/ for detailed information on this issue.
Posted Jun 26, 2024 - 05:44 PDT
This incident affected: Denticon (Practice Management, Reports).