Legwork - Patient Engagement Performance Degraded
Incident Report for Planet DDS
Resolved
The incident is now resolved.
Posted Nov 27, 2024 - 07:28 PST
Update
We are continuing to work with Twilio to build and deploy a fix for the issue.
Posted Nov 26, 2024 - 18:19 PST
Update
We are continuing to work with Twilio to build and deploy a fix for the issue.
Posted Nov 26, 2024 - 16:04 PST
Identified
The root cause for the issue is identified and Twilio customer service is working on preparing a fix for the issue.
Posted Nov 26, 2024 - 15:00 PST
Investigating
We’re currently experiencing degraded performance with our partner Twilio. This is impacting Legwork Patient Engagement. We apologize for any inconvenience. Our team is actively working to restore service.
Posted Nov 26, 2024 - 14:18 PST
This incident affected: Legwork (Patient Engagement).