Patient Notes feature issue
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 07:58 PDT
Investigating
We are aware of an issue impacting the Patient Notes feature within Denticon when accessing notes from a scheduled appointment. We are actively investigating the issue. As a workaround you can right click on the appointments, select go to notes, and you will be directed to the normal notes screen.
Posted Sep 06, 2024 - 07:05 PDT
This incident affected: Denticon (Reports).