Legwork - Patient Engagement Service Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 14:22 PDT
Update
We are continuing to investigate this issue.
Posted Jun 06, 2024 - 12:11 PDT
Investigating
We’re currently experiencing degraded performance with one or more of our services. We apologize for any inconvenience. Our team is working to restore service back to normal operation.
Posted Jun 06, 2024 - 07:33 PDT
This incident affected: Legwork (Patient Engagement).