Denticon slow
Incident Report for Planet DDS
Resolved
We are continuing to monitor for any further issues.
Posted Jan 02, 2019 - 09:18 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 02, 2019 - 09:17 PST
Monitoring
Denticon is back up. We are still investigating the root cause and will continue to monitor.
Posted Jan 02, 2019 - 09:13 PST
Investigating
We are currently investigating the issue.
Posted Jan 02, 2019 - 09:10 PST
This incident affected: Denticon Group (Denticon).