Currently experiencing slowness
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted May 08, 2018 - 14:11 PDT
Monitoring
We have resolved the issue and are continuing to monitor the servers.
Posted May 08, 2018 - 14:07 PDT
Investigating
We are currently investigating this issue.
Posted May 08, 2018 - 13:37 PDT
This incident affected: Denticon Group (Denticon).