Denticon Imaging Performance Degraded
Incident Report for Planet DDS
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 11:45 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2024 - 11:33 PDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2024 - 11:07 PDT
Identified
The issue has been identified and a fix is being implemented. The impact of this issue has been isolated to the following domain URL: https://###.dentiray.net. All other imaging URL's are working as expected.
Posted Apr 26, 2024 - 10:46 PDT
Update
We are continuing to investigate this issue.
Posted Apr 26, 2024 - 10:24 PDT
Update
We are continuing to investigate this issue.
Posted Apr 26, 2024 - 10:06 PDT
Update
We are continuing to investigate this issue. In the meantime, please use your existing bridge to XVCapture / Dentiray Capture to view and take images.
Posted Apr 26, 2024 - 09:47 PDT
Update
Please be assured that we are aware of the inability to view images in XVWeb at this time. Our Engineering team is investigating the issue and is currently working to resolve it.

In the meantime, XVCapture/DCV/Dentiray Capture and rebrands are still working. Users should be able to open and use XVCapture to view images from XVWeb and capture new ones.
Posted Apr 26, 2024 - 09:38 PDT
Investigating
We’re currently experiencing degraded performance with one or more of our services. We apologize for any inconvenience. Our team is working to restore service back to normal operation. We will provide an update in about 15 minutes.
Posted Apr 26, 2024 - 09:19 PDT
This incident affected: Denticon Group (Denticon) and Denticon (Imaging (Apteryx)).